nested functions

Kenneth Brody kenbrody at spamcop.net
Wed Feb 25 11:53:06 PST 2015


On 2/25/2015 11:53 AM, Richard Kreiss wrote:
> This may be a Ken question:
>
> I recently needed to pass a name from one file record to a process in
> another process.  This was done by passing the command line to a system
> call and using -ry with the name from the record.
>
> However, this proved to create a problem as there was a space between the
> first and last name.  Only the first name was being passed by -ry.  My
> fault.  I then added a comma to the name value and created programming to
> remove the comma.

Put the parameter in quotes:

     -ry "Bob   Smith"

[...]
> My question is how complex can one use before filePro has a problem
> handling it. (assuming that the functions are used properly)

What do you mean by "how complex can one use"?

> The next question, for clarity in programming is the programmer better
> off keeping things simpler?

Unless there is a compelling need, such as "this line is going to be 
executed a million times, so shaving a millisecond per iteration really adds 
up", then you're probably better off with clear code than complex (but 
"faster", or "tighter") code.

-- 
Kenneth Brody


More information about the Filepro-list mailing list